Scanner Epson V10

Guida aggiornata il 12/02/2013
Questa guida è stata testata su:
Lucid Lynx
Precise Pangolin
Lenny 5.0.8
Squeeze 6.0

Recentemente ho acquistato questo scanner.
Lo collego nella porta usb e controllo se viene rilevato dal sistema, lanciando il comando:
lsusb
e viene rilevato:
Bus 005 Device 002: ID 04b8:012d Seiko Epson Corp. Perfection V10/V100 (GT-S600/F650)

Purtroppo non viene rilevato da Xsane, quindi vanno installati i driver proprietari dello scanner, disponibili a questo indirizzo, oppure in questa pagina.

Edit del 12/02/2013: dal 20 gennaio 2013, il donwload dei driver è disponibile al seguente indirizzo; qui il comunicato.

Nel sito del produttore sono presenti i pacchetti in formato .deb, (fate attenzione a scaricare i pacchetti adatti al rilascio di Ubuntu o Debian in uso );

Ubuntu

Istruzioni per rilasci a partire da Lucid Lynx

Scaricate i seguenti pacchetti, tenendo conto dell’architettura del pc (32 bit o 64 bit):

  • iscan-data_[versione corrente]_all.deb
  • iscan_[versione corrente]~usb0.1.ltdl7_i386.deb
  • iscan-plugin-gt-s600_[versione corrente]_i386.deb

qui è indicato il pacchetto per l’architettura a 32 bit.

Oltre ai tre pacchetti .deb, si deve installare anche il pacchetto libltdl7, con il seguente comando:
sudo apt-get install libltdl7

oppure facendo clic qui.

Debian

Istruzioni per Lenny 5.0.8

Scaricate nella Home i seguenti pacchetti:

  • iscan-data_[versione corrente]_all.deb
  • iscan_[versione corrente]~usb0.1.ltdl3_i386.deb
  • iscan-plugin-gt-s600_[versione corrente]_i386.deb

Oltre ai tre pacchetti .deb, si deve installare anche il pacchetto libltdl3, con il seguente comando:
sudo apt-get install libltdl3

oppure facendo clic qui

Istruzioni per Squeeze 6.0

Scaricate i seguenti pacchetti:

  • iscan-data_[versione corrente]_all.deb
  • iscan_[versione corrente]~usb0.1.ltdl7_i386.deb
  • iscan-plugin-gt-s600_[versione corrente]_i386.deb

Oltre ai tre pacchetti .deb, si deve installare anche il pacchetto libltdl7, con il seguente comando:
sudo apt-get install libltdl7
oppure facendo clic qui
Infine installare i due pacchetti, come indicato nella seguente guida.

Passaggi comuni

Installare i seguenti pacchetti:

facendo clic sui link presenti oppure con il seguente comando:
sudo apt-get install libsane-extras sane

Aprire il file dll.conf, digitando in una finestra di terminale il seguente comando:
gksudo gedit /etc/sane.d/dll.conf

cercare la seguente riga:
epson

e sostituirlo con:

#epson

infine modificare il file 45-libsane.rules:

gksudo gedit /etc/udev/rules.d/45-libsane.rules
e aggiungere il seguente testo:
# Epson Perfection V10
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="012d", MODE="664", GROUP="scanner"

Infine riavviare il pc .

Questa voce è stata pubblicata in Debian, Guide, Guide-Ubuntu, Hardware e contrassegnata con . Contrassegna il permalink.

9 risposte a Scanner Epson V10

  1. Pingback: Scanner Epson V10

  2. waka_jawaka scrive:

    “Infine riavviare il pc”

    Magari basta riavviare udev, o magari basta aggiungere l’utente al gruppo scanner e riloggarsi; o magari ancora (come è appena successo a me con un perfection 2480 su arch linux) basta solo lanciare iscan (dipende come hai creato l’utente )… magari fai un pò tu, ma ti prego: riavviare il pc proprio no.
    Ciao

  3. totò scrive:

    Ehm, :oops:
    sinceramente non ci avevo pensato a riavviare udev, grazie per la segnalazione :smile:

    ciao

  4. pinzia scrive:

    Spiegami perché nel 2009 su gnu/linux dobbiamo esser ancora esser messi così male con gli scanner.
    Per le webcam si sta migliorando il supporto, per i modem anche (dicono), per le stampanti molto bene mentre per gli scanner niente…
    Possibile?

  5. totò scrive:

    @ pinza
    secondo me è questione di tempo. :smile:
    Vedi per esempio l’articolo sulla scheda wifi;
    per farla funzionare su Hardy Heron, dovevo installare i driver per Windows XP tramite Ndiswrapper, non c’era neanche un pacchetto in formato .rpm :sad:(con alien lo convertivo in .deb).
    Invece ora con Jaunty Jackalope non devo fare più nulla :smile:, quindi sono fiducioso che con il tempo, le varie periferiche saranno riconosciute dal sistema in maniera autonoma :smile:

  6. Silvan scrive:

    Volevo chiedervi se questa procedura potrebbe funzionare anche per Epson perfection V300 con UBUNTU 10.04.
    Grazie in anticipo a tutti.

  7. totò scrive:

    @ Silvan
    sinceramente non lo so, io ho testato solo questo modello, comunque prova :smile:
    visto che usi Lucid, i pacchetti .deb da scaricare sono:

    DEB 32bit package [libltdl7] (for Ubuntu 8.10 or later)

    iscan_2.24.0-4.ltdl7_i386.deb

    esci-interpreter-gt-f720_0.0.1-2_i386.deb

    fammi sapere :wink:

  8. Silvan scrive:

    @ totò
    Grazie totò, ti confermo che funziona anche per epson perfection V300.
    1)Ho installato libltdl7 da terminale con il comando sudo apt-get install libltdl7
    2) Ho scaricato e installato DEB 32bit package [libltdl7] (for Ubuntu 8.10 or later)

    iscan_2.24.0-4.ltdl7_i386.deb

    esci-interpreter-gt-f720_0.0.1-2_i386.deb
    3) ho eseguito da terminale il comando gksudo gedit /etc/sane.d/dll.conf
    Però nel mio caso era già presente il # davanti a epson per cui ho chiuso senza modificare nulla.
    4)Ho eseguito il comando da terminalle gksudo gedit /etc/udev/rules.d/45-libsane.rules
    5)Ho copiato nel riquadro (che era completamente bianco) la seguente scritta
    # Epson Perfection V300
    SYSFS{idVendor}==”04b8″, SYSFS{idProduct}==”012d”, MODE=”664″, GROUP=”scanner”
    6)Ho salvato e sono uscito.
    7)Ho riavviato.
    Lo scanner V300 adesso funziona sia con Iscan che con Xsane e anche con simple scan.
    In pratica ho cambiato solo V10 in V300 rispetto alla procedura di cui sopra.
    Ti ringrazio tanto.
    Ciao Silvan

  9. totò scrive:

    @ Silvan
    figurati :wink:

    ciao :smile:

I commenti sono chiusi.

Related Post by category:

  1. Debian 6.0 “Squeeze”
  2. Scanner Canon N640P